DIP 1003 Formal Review

rjframe via Digitalmars-d digitalmars-d at puremagic.com
Sat May 13 05:00:05 PDT 2017


On Fri, 12 May 2017 16:17:03 +0000, Mike Parker wrote:

> The first stage of the formal review for DIP 1003 [1], "Remove body as a
> Keyword", is now underway. From now until 11:59 PM ET on May 26 (3:59 AM
> GMT on May 27), the community has the opportunity to provide last-minute
> feedback. If you missed the preliminary review [2], this is your chance
> to provide input.
> 
> At the end of the feedback period, I will submit the DIP to Walter and
> Andrei for their final decision. Thanks in advance to those of you who
> participate.
> 
> [1]
> https://github.com/dlang/DIPs/blob/
fbb797f61ac92300eda1d63202157cd2a30ba555/DIPs/DIP1003.md
> 
> [2]
> http://forum.dlang.org/thread/qgxvrbxrvkxtimzvnetu@forum.dlang.org


For option one, there would also need to be a discussion of whether to 
allow us to use in and out as identifiers for consistency (I used them 
more often than body in my pre-D programming); I would say no, but could 
argue either way. It's a slippery slope.


I think option three is ugly, but I could live with it. I thought ()() was 
ugly for templates too, but now they're just normal.

How about:

void func()
in { assert(true); }
out { assert(true); }
nowWeFinallyGetToTheFunctionBodyProvidedThereWereNoProblems {
	// I don't think we'll have to worry about name clashes...
}


More information about the Digitalmars-d mailing list