DIP 1020--Named Parameters--Community Review Round 2

Jonathan Marler johnnymarler at gmail.com
Tue Sep 10 18:47:54 UTC 2019


On Tuesday, 10 September 2019 at 09:06:23 UTC, Mike Parker wrote:
> This is the feedback thread for the second round of Community 
> Review for DIP 1020, "Named Parameters":
>
> https://github.com/dlang/DIPs/blob/c723d8f4e3ac2d5bcaf8cdff87e1507f09669ca6/DIPs/DIP1020.md
>
> All review-related feedback on and discussion of the DIP should 
> occur in this thread. The review period will end at 11:59 PM ET 
> on September 24, or when I make a post declaring it complete.
>
> At the end of Round 2, if further review is deemed necessary, 
> the DIP will be scheduled for another round of Community 
> Review. Otherwise, it will be queued for the Final Review and 
> Formal Assessment.
>
> Anyone intending to post feedback in this thread is expected to 
> be familiar with the reviewer guidelines:
>
> https://github.com/dlang/DIPs/blob/master/docs/guidelines-reviewers.md
>
> *Please stay on topic!*
>
> Thanks in advance to all who participate.

Sorry in advance for the bikeshedding, but using the @ symbol 
just looks ugly to me. How about using 'public' instead of 
'@named'?

     void foo(@named bool log, @named bool goFast);
Vs.
     void foo(public bool log, public bool goFast);


More information about the Digitalmars-d mailing list