DIP 1020--Named Parameters--Community Review Round 2
johnnymarler at gmail.com
Wed Sep 11 16:08:59 UTC 2019
On Wednesday, 11 September 2019 at 05:15:04 UTC, rikki cattermole
> On 11/09/2019 6:47 AM, Jonathan Marler wrote:
>> Sorry in advance for the bikeshedding, but using the @ symbol
>> just looks ugly to me. How about using 'public' instead of
>> void foo(@named bool log, @named bool goFast);
>> void foo(public bool log, public bool goFast);
> I considered this quite some time ago.
> It works for templates, but it does not work for functions.
Why wouldn't it work for functions?
More information about the Digitalmars-d