DIP 1029---Add throw as Function Attribute---Community Review Round 1
nise at nise.com
Tue Jan 14 11:53:17 UTC 2020
I agree with this change. The suggested solution will have very
little or no impact on the current codebase while adding a useful
I was originally for that we should use the "throws" keyword in
order to make it more searchable. However, now when I see the
solution and that "nothrow" will still remain I think that
"throw" is better for symmetry with "nothrow".
Correct me if I'm wrong, what I've understood in the text is that
making "nothrow" the default is also a goal which is not covered
in this DIP but perhaps in a future DIP.
More information about the Digitalmars-d