<br>Simen & Marianne too:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;"><div class="im"><br></div>
There are other concerns than simply what works. First of all is<br>
readability - having containers called queue and stack makes code easier<br>
to understand, even if this is done with a simple alias.<br>
There might also be a concern about efficiency, as there is a difference<br>
in how fast different containers can push and pop.<br>
<br>
-- <br><font color="#888888">
Simen<br>
</font></blockquote></div><br>Yeah, particularly if having both stack and queue just costs one alias. I mean, it's a standard library. I know I can use built-in arrays (for example) as stacks and queues, but sometimes I just want to have a stack.<br>
<br>Initially in my mind, that was just to make some graph algorithms clearer.<br><br><br> Philippe<br>