<div dir="ltr">On 3 September 2013 18:04, Gary Willoughby <span dir="ltr"><<a href="mailto:dev@nomad.so" target="_blank">dev@nomad.so</a>></span> wrote:<br><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Requiring IDE assistance to make code _readable_ seems completely fail to<br>
me.<br>
1) You're not always reading code in your IDE, often in commit logs, diff<br>
windows, emails, chat clients.<br>
2) With so much hate for IDE support, it seems like a massive contradiction<br>
to say that an IDE should be required to make code readable.<br>
<br>
Reading code is the most fundamental task in programming. Anything that<br>
gets in the way of code readability is an epic fail.<br>
</blockquote>
<br></div>
You're still confusing code readability with getting an overview of a class. They are two different things.<br></blockquote><div><br></div><div>They're not different, it's a subset.</div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

If you need an overview that you can view in text, add comments at the top of the class with a method signature on each line. That will give you the overview you need and reproduce the total nightmare of keeping it in sync with the methods. Something you would also have to do with separate declarations and implementations.<br>

</blockquote><div><br></div><div>I think it's MUCH more of a nightmare trying to organise a class to be as readable as possible with this limitation. I'm always juggling the code, moving shit around, most of the time there's no perfect solution, and every time, it's a waste of time and money. Things often demand to be grouped either conceptually, or by visibility, and you can't have both. Visibility blocks like public:/private: basically enforce you split up your variables into a few different areas, and once they become interleaved with functions, you're screwed.</div>
</div></div></div>