<div dir="ltr"><div>I think adding new keyword/attribute just for readability is overkill.</div><div><br></div><div>Kenji Hara</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">2013/12/18 ilya-stromberg <span dir="ltr"><<a href="mailto:ilya-stromberg-2009@yandex.ru" target="_blank">ilya-stromberg-2009@yandex.ru</a>></span><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5">On Wednesday, 18 December 2013 at 11:10:10 UTC, QAston wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
On Wednesday, 18 December 2013 at 03:42:46 UTC, Kenji Hara wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<a href="http://wiki.dlang.org/DIP53" target="_blank">http://wiki.dlang.org/DIP53</a><br>
Redesign currently implemented qualified constructor concept.<br>
<br>
<a href="http://wiki.dlang.org/DIP49" target="_blank">http://wiki.dlang.org/DIP49</a><br>
Improved points from version 1:<br>
- Swap meanings of 'this(this) inout' and 'this(this) const'<br>
- Inout postblit now covers all cheap (== not rebind indirections) copies between same qualifiers<br>
<br>
Kenji Hara<br>
</blockquote>
<br>
This is awesome, maybe I'll be able to use immutable in my code, thanks to this and your bugfixes (opAssign)!<br>
<br>
One suggestion though - maybe @unique would be better than const for unique postblit/constructor, I think static confusion is an important lesson from the past.<br>
</blockquote>
<br></div></div>
I agree, `@unique` attribute looks more clear.<br>
BTW, we can use `unique` keyword for unique postblit/constructor. Also, we can use this keyword for unique storage class of variables and related issues.<br>
</blockquote></div><br></div>