<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="">> Not everyone will ever get satisfied.<br>

</div>Indeed. I can only compromise so much, until it becomes compromised.<br>
</blockquote></div><br></div><div class="gmail_extra">Naming is one of the two hard problems (along with cache invalidation and off-by-one errors).</div><div class="gmail_extra"><br></div><div class="gmail_extra">We can argue about these things forever, but ultimately all that really matters is: does it do what we need?  As long as the API works, and lets one build fancier functionality underneath, it is good.  (Though, in my experience, any API written will be wrong the first try)</div>
<div class="gmail_extra"><br></div><div class="gmail_extra"><br></div><div class="gmail_extra">That said, my bikeshed preferences are:</div><div class="gmail_extra"> - namespaced <a href="http://log.info">log.info</a>, log.warning, etc</div>
<div class="gmail_extra"> - info(f) matching write(f)</div><div class="gmail_extra"> - conditionals as an extension/wrapper, not part of base</div><div class="gmail_extra"><br></div><div class="gmail_extra"><br></div></div>