<div dir="ltr"><div><div><div><div><div><div><div><div>Not a naming suggestion, but a suggestion for a guideline on how to chose names: make it simpler for most users.<br></div><div><br>If we still want one million users:<br><br></div>1. Most of them will never bother with std.allocator (by which I don't mean it is not necessary!)<br></div>2. Of those relatively few using std.allocator, most will use the canned, easy-to-use, high-level stuff<br></div>3. Just a few users will reach the plumbing.<br><br></div>As someone personally prefering to remain in group 1 forever, but I willing to visit group 2 occasionally if necessary, I'd prefer to simply say<br><br></div>import std.allocator;<br><br></div>and get access to the higher-level stuff instead of <br><br>import std.allocator.whatever;<br><br></div>This has implications even for the hypothetical day in which I'll be required to use std.allocator. The closer to the root I find the stuff I need (that is, the high-level stuff), the quicker I'll find it. If I find lower-level stuff before finding the higher-level ones, I might even be fooled to believe that I don't have better (better for me) alternatives, and start a path of unnecessary suffering.<br><br></div><div>The bottom line: please make the naming reflect the expected usage, taking into account the mythical one million users. Simpler names for the stuff that will be used by most of us.<br><br></div><div>Cheers,<br><br></div><div>LMB<br></div><div><br></div><br><div><div><br><br><br><div><div><div><br><div><div><div><br><br></div></div></div></div></div></div></div></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Fri, May 15, 2015 at 12:27 AM, Andrei Alexandrescu via Digitalmars-d <span dir="ltr"><<a href="mailto:digitalmars-d@puremagic.com" target="_blank">digitalmars-d@puremagic.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Ready for yet another name debate? Here's an opportunity!<br>
<br>
I just added:<br>
<br>
<a href="http://erdani.com/d/phobos-prerelease/std_experimental_allocator_auto_deallocator.html" target="_blank">http://erdani.com/d/phobos-prerelease/std_experimental_allocator_auto_deallocator.html</a><br>
<br>
<a href="https://github.com/andralex/phobos/blob/allocator/std/experimental/allocator/auto_deallocator.d" target="_blank">https://github.com/andralex/phobos/blob/allocator/std/experimental/allocator/auto_deallocator.d</a><br>
<br>
It's very useful, but it seems the name doesn't do it justice.<br>
<br>
Also, I need two more good names: one for what's now called "porcelain" - high-level typed interface for allocators, and one for "best of Beatles" (not defined yet) - a module collecting a number of canned good allocator designs by connecting together components.<br>
<br>
<br>
Thanks,<br>
<br>
Andrei<br>
</blockquote></div><br></div>