[phobos] Ranges using runtime interfaces

Shin Fujishiro rsinfu at gmail.com
Fri Aug 20 18:26:07 PDT 2010

David Simcha <dsimcha at gmail.com> wrote:
> In addition to the changes I made last night, I've also made the 
> following changes:
> 1.  Change name to inputRangeObject/InputRangeObject.
> 2.  Add support for output ranges as outputRangeObject/OutputRangeObject.
> 3.  Remove the now ridiculous looking Hungarian notation on the interfaces.
> http://pastebin.com/U83YNJfJ is where it's at.
> Any more comments from anyone, or does this look ready to be checked in?

Could you make OutputRangeObject able to accept multiple element types?

template outputRangeObject(E...) {
    auto outputRangeObject(R)(R range) { ... }


More information about the phobos mailing list