How to get MinTL working?

xycos xycos at
Mon Aug 28 17:51:31 PDT 2006

Hi. Sorry to ask such a dumb question; I've been poking around for the 
last four hours, but my complete inexperience with anything more
complex than adding a JAR file to a Java project seems to have gotten
the better of me. How can I get MinTL working (I'm using the
code::blocks IDE on Windows XP... if there's an easy way to do it
there, but I can always add compiler switches). For the time being, I
just want to figure out how t get it working on the command-line.

Here's what I tried as per

Using the test program from the site:
import mintl.list;

int main() {
  List!(int) list = List!(int).make(10,20,30);
  return 0;

- I tried to compile and run the example test program. When compiling
it, ("dmd app.d mintl\mintl_debug.lib" or "dmd app.d -release
mintl\mintl.lib"), I get:
mintl\share.d:40: template instance identifier 'va_arg' is not defined
mintl\share.d:40: template instance 'va_arg!(int)' is not a variable
mintl\share.d:40: function expected before (), not va_arg!(int) of
type int
- I also tried to rebuild the library using the makefile using "make
-f win32.mak" After a couple messages saying the "l" suffix is
depreciated for "L", I get "--- errorlevel 1", with no indication of
what the error is.

Anyway, I guess D definitley isn't a newbie-friendly language.

Thanks for any responses!

P.S. I know there's a DTL newsgroup, but it doesn't seem particularly

More information about the Digitalmars-d-learn mailing list