Dear toolchain...

Simen Haugen simen at
Tue Mar 10 11:38:36 PDT 2009

Jarrett Billingsley wrote:
> On Tue, Mar 10, 2009 at 1:45 PM, Simen Haugen <simen at> wrote:
>> I'm waist deep in problems, and have no idea how to get up.
>> I have a program that uses d1, dmd, tango, ddbi, dwt and dwin. Some time ago
>> I discovered that the program would no longer compile, and I have several
>> features and bugfixes long overdue.
>> It seems the problem happens during linking, but as I get no error what so
>> ever it's a bit hard for me to track down. The project is about 30kloc.
>> I've tried both dsss and rebuild. Dsss at least says rebuild exits with a
>> status code 1, but still no hints on where the error might be.
>> My guess is that this is a bug with lib.exe or link.exe, but I might be far
>> off...
>> I'm using D for several other programs, but don't keep a log for what
>> versions I used when the projects last compiled... I've tried several
>> different versions of both the compiler and the various libs, but as I said,
>> I keep no log, so it's kind of a shot in the dark...
>> I've spent at least 8 hours so far trying to locate the error with no luck.
>> Does anyone have any good ideas how I can proceed?
>> Or perhaps a pointer in the direction for narrowing down my search?
> Verbose flags!  That should help narrow down where the
> compilation/linking fails.

I've tried that. Rebuild keeps compiling files until I get the command 
prompt with no message. I don't see any message showing the linking 
begins, but if I exclude the last file from my project, the same thing 
happens (in other words - I know all the files compiles correctly). 
X-Files ...

More information about the Digitalmars-d-learn mailing list