getChar() vs. getChar!true()
Ali Çehreli
acehreli at yahoo.com
Wed Mar 20 13:27:17 PDT 2013
On 03/20/2013 01:11 PM, Peter Sommerfeld wrote:
> In std.json is a function getchar() with this signature:
>
> dchar getChar(bool SkipWhitespace = false);
That 'false' up there is the default value of SkipWhitespace.
> But it is called differently:
>
> getChar(); // obviously SkipWhitespace = true;
No, in that case SkipWhitespace==true.
> getChar!true(); // probably getchar(true)
>
> What is the reason for the different notation ?
The same thing; just being explicit.
Aside: bool parameters (regular or template) hurt readability. It would
be better to have defined a type similar to std.stdio.KeepTerminator and
its use with byLine():
http://dlang.org/phobos/std_stdio.html#.File.byLine
Ali
More information about the Digitalmars-d-learn
mailing list