is opOpAssign returning a value less than ideal ?
Codifies
a at b.com
Thu Nov 8 04:28:19 UTC 2018
I noticed that opOpAsign allows you to return a value...
this means I can do this (return a node from my list class when
adding a new node)
```
anode = alist ~= &someData;
```
to me this looks a little unusual (but to be fair I can live with
it)
being as when its used like this:
```
alist ~= &someData;
```
you need to find out what the ~ operator does anyway, I don't
think it harms readability
any thoughts?
More information about the Digitalmars-d-learn
mailing list