D1: Trying to update Juno Library to 1.076

jicman jicman at gmail.com
Fri Aug 23 17:50:52 UTC 2019

On Friday, 23 August 2019 at 17:18:55 UTC, a11e99z wrote:
> On Friday, 23 August 2019 at 17:03:24 UTC, jicman wrote:
>> On Friday, 23 August 2019 at 16:49:07 UTC, a11e99z wrote:
>>> right now problem exists with linker/libs only, compiler see 
>>> all used VarXXX
>> First of all, thanks for your patient support.
>> to the above program, and still fails with the same error.  I 
>> also went and downloaded the latest D1 linker, and that also 
>> results in the same failure.
> another try:
> zip ur dmd 1.076 folder (for easy restoring it when something 
> go wrong)
> copy lib files from 1.046\lib\*.lib to 1.076\lib\*.lib
> try to compile program again with dmd 1.076

TA-DAH!  Weird stuff.  The 1.046 libraries worked.  Very weird 
stuff.  Now to try to figure out how that happened, since I took 
**all** 1.076 from the download site.  Which means, that it may 
be have outdated libraries.  That's for another day, though.  
Muchas gracias, as we say in Spanish.  But, I'll translate for 
you, Thanks very much.


More information about the Digitalmars-d-learn mailing list