Can't get dub dustmite to work

aliak something at
Sat Apr 25 09:38:59 UTC 2020

Trying to get dub dustmite to work, but I keep getting "initial 
test fails"

This is the error from a vanilla dub test:

result ~wip: building configuration "result-test-unittest"...
inout(SumType!(int, FailureContainer))
Error: static assert:  "handler #1 of type Optional!(Exception) 
function(FailureContainer container) pure nothrow @nogc @safe 
never matches"
        instantiated from here: matchImpl!(inout(SumType!(int, 
source/result/result.d(136,20):        instantiated from here: 
match!(inout(SumType!(int, FailureContainer)))
tests/result.d(20,20):        instantiated from here: 
Result!(int, Exception)
dmd failed with exit code 1.

Then I run this dub dustmite command:

dub dustmite -b unittest ../dubdust --compiler-regex="never 

And I get:

Loading /Users/aliak/dev/dubdust/vibe-d/web/vibe/web/web.d
None => No
Hint: use --no-redirect to see test script output
Hint: read
object.Exception at DustMite/dustmite.d(295): Initial test fails: 
Test script "/usr/local/Cellar/dub/1.20.0/bin/dub dustmite 
--vquiet --test-package=result --build=unittest --config=library 
\"--compiler=dmd\" \"--compiler-regex=never matches\"" exited 
with exit code 3 (failure)

* --no-redirect doesn't work in dub dustmite.
* I tried adding --compiler-status=1 with the same result
* I tired --combined with the same result

My dub.json for the unittest configuration is (incase that 
             "name": "unittest",
             "importPaths": [
             "sourcePaths": [

Thanks for any help!

More information about the Digitalmars-d-learn mailing list