Small feature request
Koroskin Denis
2korden at gmail.com
Sat Mar 29 14:02:27 PDT 2008
On Sat, 29 Mar 2008 23:01:26 +0300, Janice Caron <caron800 at googlemail.com>
wrote:
> On 29/03/2008, Koroskin Denis <2korden at gmail.com> wrote:
>> Look at this class.
>>
>> class Buffer
>> {
>> private int bufferSize = 4096;
>> private void[bufferSize.init] buffer = void;
>> }
>
> In the current (D2.012) regime, that should be
>
> class Buffer
> {
> private enum bufferSize = 4096;
> private void[bufferSize] buffer = void;
> }
I would declare it as "static const int" if I needed a constant value.
An example is probably bad but I needed a /mutable/ variable by design.
More information about the Digitalmars-d
mailing list