A possible solution for the opIndexXxxAssign morass

Andrei Alexandrescu SeeWebsiteForEmail at erdani.org
Tue Oct 13 10:08:59 PDT 2009


Bill Baxter wrote:
> Huh? It didn't sound to me like it would get rid of anything, except
> for the use of the word "index" in many methods that have to do with
> index operations.  That just seems confusing to me.   I think the
> opIndexXxxAssign functions may need to be added, but adding them by
> overloading existing names doesn't seem a win to me.
> 
> --bb

That's a good point. But something is inherently problematic about name 
explosion (In the proposed solution there is still an explosion in the 
count of functions that need to be written.)

Now I realize there's also a need for opSliceXxxAssign, bleh. Unless we 
ascribe a distinct type to a .. b.


Andrei



More information about the Digitalmars-d mailing list