std.container update
Jonathan M Davis
jmdavisProg at gmail.com
Fri May 28 05:09:51 PDT 2010
Simen kjaeraas wrote:
> I take it you don't work in simulation or games, then? Don't do much
> linear algebra?
>
> While I understand the reasoning for it, I dislike the name vector for
> arrays. A vector to me, is a geometric object with a length and magnitude,
> not a random collection of whatevers.
Vector is arguably a poor name because of that. However, it is, at this
point, a very standard name for such a container. At minimum, both C++ and
Java have a vector class, though the main one that you'd use in Java at this
point would be ArrayList rather than Vector. So, if a better name can be
found, that's great, but Vector is quite a standard name for the concept at
this point, and I do think that it works better than Array. I also don't
like the name ArrayList because I wouldn't really consider a vector to be a
list, but that's another option. I'm not all that familiar with what other
languages have used for such a class, but there are probably other pre-
existing options out there as well.
- Jonathan M Davis
More information about the Digitalmars-d
mailing list