Stupid little iota of an idea
spir
denis.spir at gmail.com
Fri Feb 11 16:37:01 PST 2011
On 02/12/2011 12:55 AM, Andrei Alexandrescu wrote:
> Not all users dislike iota, and besides arguments ad populum are fallacious.
> Iota rocks. But have at it - vote away, and I'll be glad if a better name for
> iota comes about.
Proposed "interval" (which I understand as a quasi-synonym of range, apart from
D's use of the term). 1-2 more people seemed to find it appropriate. Bearophile
argued interval is ok but too long for such a common (?)(*) feature. What do
you think?
Denis
(*) The notion is indeed somewhat common in code, but we have i..j for the most
common cases, by far. iota() is only for when we need an assignable value
representing an interval.
--
_________________
vita es estrany
spir.wikidot.com
More information about the Digitalmars-d
mailing list