Integer conversions too pedantic in 64-bit
Nick Sabalausky
a at a.a
Mon Feb 14 17:58:17 PST 2011
"Jonathan M Davis" <jmdavisProg at gmx.com> wrote in message
news:mailman.1650.1297733226.4748.digitalmars-d at puremagic.com...
> On Monday, February 14, 2011 17:06:43 spir wrote:
>>
>> Rename size-t, or rather introduce a meaningful standard alias? (would
>> vote
>> for Natural)
>
> Why? size_t is what's used in C++. It's well known and what lots of
> programmers
> would expect What would you gain by renaming it?
>
Although I fully realize how much this sounds like making a big deal out of
nothing, to me, using "size_t" has always felt really clumsy and awkward. I
think it's partly because of using an underscore in such an otherwise short
identifier, and partly because I've been aware of size_t for years and still
don't have the slightest clue WTF that "t" means. Something like "wordsize"
would make a lot more sense and frankly feel much nicer.
And, of course, there's a lot of well-known things in C++ that D
deliberately destroys. D is a different language, it may as well do things
better.
More information about the Digitalmars-d
mailing list