const(Object)ref is here!
Bruno Medeiros
brunodomedeiros+spam at com.gmail
Thu Jan 27 07:43:46 PST 2011
On 21/12/2010 18:19, Steven Schveighoffer wrote:
> On Tue, 21 Dec 2010 13:10:12 -0500, Bruno Medeiros
> <brunodomedeiros+spam at com.gmail> wrote:
>
>> On 06/12/2010 19:00, Jonathan M Davis wrote:
>>> On Monday, December 06, 2010 05:41:42 Steven Schveighoffer wrote:
>>>
>>> I have no problem with writeTo(). I just couldn't remember what it
>>> was and
>>> didn't want to take the time to look it up, and the name isn't as
>>> obvious as
>>> toString(), since it's not a standard name which exists in other
>>> languages, and
>>> it isn't actually returning anything. Whether it's to or from would
>>> depend on
>>> how you look at it - to the given delegate or from the object. But
>>> writeTo() is
>>> fine. Once it's used, it'll be remembered.
>>>
>>
>> I don't think it's entirely fine. It should at least have
>> "string"/"String" somewhere in the name. (I mentioned this on the
>> other original thread, although late in time)
>
> First, I'll say that it's not as important to me as it seems to be to
> you, and I think others feel the same way. writeTo seems perfectly fine
> to me, and the 'string' part is implied by the char[] parameter for the
> delegate.
>
> Changing the name to contain 'string' is fine as long as:
>
> 1) it's not toString. This is already established as "returning a
> string" in both prior D and other languages. I think this would be too
> confusing.
> 2) it's short. I don't want writeAsStringTo or something similar.
>
> What did you have in mind?
>
> -Steve
Sorry for the long delay in replying..
I don't have any specific favorite name. Could be writeString, asString,
stringWrite, ouputString, even toString (despite a different signature
from other languages), etc.
Or a similar name with Text instead of String, as Andrei suggested
(although I'm not 100% sure about that last one).
It's just that I would prefer the String connotation to be implied in
the function name, not just implied in the parameter (makes the code
clearer, in a somewhat subjective opinion). And also to not take up the
"writeTo" overload in all Objects ever, as some might want to use that
overload name for their own stuff.
--
Bruno Medeiros - Software Engineer
More information about the Digitalmars-d
mailing list