Small Buffer Optimization for string and friends
Andrej Mitrovic
andrej.mitrovich at gmail.com
Mon Apr 9 09:03:06 PDT 2012
On 4/9/12, Jakob Ovrum <jakobovrum at gmail.com> wrote:
> With all the focus on manual memory
> management and pluggable allocators going on, I think the
> optimization must be removed or the documentation for the
> `string` overload changed.
Or add a compile-time argument:
toStringz(bool ForceAllocate = true)(string s)
Or split the unsafe version into another function.
More information about the Digitalmars-d
mailing list