s/type tuple/template pack/g please
captaindet
2krnk at gmx.net
Wed Aug 21 12:48:59 PDT 2013
On 2013-08-21 13:36, Meta wrote:
> On Wednesday, 21 August 2013 at 18:26:42 UTC, Andrei Alexandrescu
> wrote:
>> We much more need to get "type" out of the name. Those aren't
>> types.
>
> I think this is part of the problem. Nobody can agree on what they
> should be called because it's so hard to classify them. They're not
> types, they're not values, they're this weird in-between thing that
> can be either one, or the other, or both. Therefore anything
> containing Type or Value in the name will not describe exactly what
> this thing is. Neither will Symbol, nor Expression, as it can contain
> both of those again, but not exclusively. We may as well call it by
> some name that is completely unrelated to what it can contain, as it
> can contain pretty much *everything*. How about KitchenSinkquence?
abstract tuples they are.
(we have to alias them to maintain their full function)
i don't mind them being called ...tuples, to me it looks and feels enough like a tuple to be called this way. (Type... is very confusing though).
concerning the other typecons.Tuple: i think of this being more an issue of insufficient/bad/confusing documentation.
/det
More information about the Digitalmars-d
mailing list