DIP53 and DIP49 (ver2) - New definitions for qualified constructors and postblits

ilya-stromberg ilya-stromberg-2009 at yandex.ru
Wed Dec 18 09:33:06 PST 2013


On Wednesday, 18 December 2013 at 15:20:39 UTC, Kenji Hara wrote:
> I think adding new keyword/attribute just for readability is 
> overkill.
>
> Kenji Hara

We can use `unique` keyword as unique storage class of variables 
in future if we decide that this feature can be useful.
It's not my idea, see `std.exception.assumeUnique`:
"Checking for uniqueness during compilation is possible in 
certain cases (see the unique and lent keywords in the ArchJava 
language), but complicates the language considerably.".

We already have reserved `macro` keyword for AST macros, so add 
one more reserved keyword for possible language improvement is 
not so terrible. But, of course, it's only my IMHO.


More information about the Digitalmars-d mailing list