std.compress
Jonathan M Davis
jmdavisProg at gmx.com
Tue Jun 4 23:59:59 PDT 2013
On Tuesday, June 04, 2013 23:55:05 Timothee Cour wrote:
> What I suggested in my original post didn't involve any
> indirection/abstraction; simply a renaming to be consistent with existing
> zlib (see my points A+B in my 1st post on this thread):
>
> std.compress.zlib.compress
> std.compress.zlib.uncompress
> std.compress.lzw.compress
> std.compress.lzw.uncompress
>
> same reason we have: std.file.write, std.stdio.write, etc, and not
> std.fileWrite, std.stdioWrite.
So, you want to create whole modules for each compression algorithm? That
seems like overkill to me. What Walter currently has isn't even 1000 lines
long (and that's including the CircularBuffer helper struct). Splitting it up
like that seems like over-modularation to me.
- Jonathan M Daivs
More information about the Digitalmars-d
mailing list