std.allocator ready for some abuse
Andrei Alexandrescu
SeeWebsiteForEmail at erdani.org
Sat Oct 26 23:16:22 PDT 2013
On 10/25/13 12:19 PM, Dmitry Olshansky wrote:
> - I don't like the name CAllocator. Whatever that C stands for it's
> ambiguous (Class, Cee, Caramel?).
Class. Better names welcome.
> - It may be only me but I _think_ it could be more useful to have a few
> specific interfaces then 1 fat CAllocator. I've come to dislike
> fat-interfaces with isSupported kludges but that's IMHO.
Yah it's a good idea. I'll think of it.
> - I see that shrink primitive didn't make it... Well, on the upside the
> primitives count is really low.
Yah. "Getting away with as little as you can" is my mantra :o).
> - In description of chooseAtRuntime:
> HeapBlock!chooseAtRuntime --> HeapBlock!(Allocator, chooseAtRuntime)
Fixed and pushed.
https://github.com/andralex/phobos/blob/allocator/std/allocator.d
Andrei
More information about the Digitalmars-d
mailing list