Good name for f.byLine.map!(x => x.idup)?

Dicebot public at dicebot.lv
Tue Mar 18 08:03:16 PDT 2014


On Tuesday, 18 March 2014 at 14:57:30 UTC, Regan Heath wrote:
> Why this fixation on "by"?
>
> lines
> allLines
> eachLine
> everyLine
>
> R

range vs container. I expect file.lines to be separate fully 
allocated entity that can be assigned and stored. file.byLines 
implies iteration without any guarantees about collection as a 
whole.


More information about the Digitalmars-d mailing list