DIP74: Reference Counted Class Objects

via Digitalmars-d digitalmars-d at puremagic.com
Fri Feb 27 00:26:13 PST 2015


On Thursday, 26 February 2015 at 22:04:09 UTC, Andrei 
Alexandrescu wrote:
> On 2/26/15 2:03 PM, Brian Schott wrote:
>>
>> One of the first things that stood out to me is that "add ref" 
>> is two
>> words and "release" is one. For the sake of symmetry, how 
>> about these:
>> *  opIncRef, opDecRef
>> *  opAcquire, opRelease
>
> All - please PLEASE do not derail this into yet another debate 
> about which names are best. -- Andrei

Using protocols rather than enforcing a particular implementation 
is nice, but D needs to stop reinventing terminology and syntax 
matters.


Acquire/Release:

https://msdn.microsoft.com/en-us/library/windows/hardware/ff540496%28v=vs.85%29.aspx


Retain/Release:

https://developer.apple.com/library/ios/documentation/Cocoa/Conceptual/MemoryMgmt/Articles/MemoryMgmt.html


AutoRelease pools / Drain:

https://developer.apple.com/library/mac/documentation/Cocoa/Reference/Foundation/Classes/NSAutoreleasePool_Class/index.html#//apple_ref/occ/instm/NSAutoreleasePool/drain


Antonyms for "release":

http://www.merriam-webster.com/thesaurus/release[verb]



More information about the Digitalmars-d mailing list