Wait, what? What is AliasSeq?
Meta via Digitalmars-d
digitalmars-d at puremagic.com
Wed Jul 8 10:12:19 PDT 2015
On Wednesday, 8 July 2015 at 16:29:25 UTC, John Colvin wrote:
> I reckon Collect would be a good name. It describes what you're
> doing: collecting some things together. Is also fits nicely
> with the currently private but hugely useful std.typetuple.Pack.
>
>
> Collect: collect things together to one symbol, but they're not
> bound together, they'll auto-expand if they can.
>
> Pack: pack things together, they only come apart explicitly
> (via .expand).
>
>
> The best thing about it? It doesn't say anything misleading
> about the contents. It also doesn't say anything confusing
> about runtime vs compile-time.
>
> Speaking as someone who's written ridiculous numbers of lines
> of code using TypeTuple and various incarnations of Pack,
> Collect fits my way of thinking.
Let's choose a name the cool kids will like and name it OmniSplat.
More information about the Digitalmars-d
mailing list