uniform tuple syntax
Vlad Levenfeld via Digitalmars-d
digitalmars-d at puremagic.com
Tue Mar 24 16:07:28 PDT 2015
On Tuesday, 24 March 2015 at 18:12:03 UTC, Martin Nowak wrote:
> I think we should settle on a syntax and split DIP32 in a tuple
> part and
> a pattern matching part.
> The proposal wasn't yet formally accepted, partly because we
> wanted to
> wait, whether more needs come up. By now it's already 2 years
> old and it
> still looks complete IMO.
>
> http://wiki.dlang.org/DIP32
Anything wrong with using {}? It looks good to me, does it lead
to any parsing ambiguities?
I just want to get all the .tuple and .expand and tuple parameter
function overload litter out of my code. My use cases are
multiple returns and parameters-first UFCS. It'd be great if
{arg1, arg2}.func1.func2;
matched the signature
auto func1 (T,U)(T arg1, U arg2);
On Tuesday, 24 March 2015 at 18:38:51 UTC, Ola Fosheim Grøstad
wrote:
> Using "$" for something completely different is confusing, but
> it looks ok. Maybe rename existing use of "$" for length to
> "#"? It can be automated.
You'd also have to rename opDollar to opHash or, maybe less
confusingly, opPound. Also, $ is already a common idiom (at least
in Unix) for "the end". It would be better to just name the
pattern matching symbol # instead.
More information about the Digitalmars-d
mailing list