std.experimental.checkedint is ready for comments!
tsbockman via Digitalmars-d
digitalmars-d at puremagic.com
Wed Jun 15 11:57:56 PDT 2016
On Wednesday, 15 June 2016 at 18:50:32 UTC, tsbockman wrote:
> What you are proposing is *not* "fixing" my design - it is
> basically scrapping it and replacing it with a ground-up
> rewrite, with perhaps some bits and pieces and general
> inspiration taken from my work.
> [...]
> If the decision is made to accept the high-level design, then
> we can go back to bikeshedding about names, fixing typos,
> tweaking/trimming the API, etc.
I should mention that one possible "trimming" would be to remove
either `SmartInt`/`smartOp` or `SafeInt`/`safeOp`. I don't *want*
to do this, obviously, but I wouldn't categorize it as "scrapping
the design", either.
More information about the Digitalmars-d
mailing list