std.database

Erik Smith via Digitalmars-d digitalmars-d at puremagic.com
Thu Mar 3 07:53:28 PST 2016


On Thursday, 3 March 2016 at 15:07:43 UTC, Kagamin wrote:
> Also member names: methods are named after verbs, you use 
> nouns. Method `next` is ambiguous: is the first row the next 
> row? `fetch` or `fetchRow` would be better.

Those are actually internal methods not intended for the 
interface user.  They might get exposed in some way to the 
implementer so I'll have to consider this issue.

However, If I apply what you are suggesting to the the interface 
methods, it would look like this:

auto r = db.connection().statement("select from t").range();  // 
nouns

auto r = db.getConnection().getStatement("select from 
t").getRange();  // verbs

Maybe there is a more creative way to change the names rather 
than prepending with get (let me know if you have suggestions), 
but the nouns seem cleaner to me.  I'll have to look at more 
phobos code to get a better sense of the conventions.  Also range 
will be replaced by an opSlice operator.

erik








More information about the Digitalmars-d mailing list