[dmd-internals] [D-Programming-Language/dmd] c72992: Replace abused WANTinterpret with NEEDinterpret
GitHub
noreply at github.com
Wed Jun 13 07:31:48 PDT 2012
Branch: refs/heads/master
Home: https://github.com/D-Programming-Language/dmd
Commit: c729923f15a22781ad1c4f6d1af89f29d72572fd
https://github.com/D-Programming-Language/dmd/commit/c729923f15a22781ad1c4f6d1af89f29d72572fd
Author: Don Clugston <don.clugston at sociomantic.com>
Date: 2012-05-13 (Sun, 13 May 2012)
Changed paths:
M src/declaration.c
M src/expression.c
M src/init.c
M src/init.h
Log Message:
-----------
Replace abused WANTinterpret with NEEDinterpret
WANTinterpret was used for two independent purposes, this removes one of them.
Commit: aff9d1740c9f747cfcc42aebf2543f423c94ab50
https://github.com/D-Programming-Language/dmd/commit/aff9d1740c9f747cfcc42aebf2543f423c94ab50
Author: Don Clugston <don.clugston at sociomantic.com>
Date: 2012-05-13 (Sun, 13 May 2012)
Changed paths:
M src/attrib.c
M src/cond.c
M src/declaration.c
M src/enum.c
M src/expression.c
M src/expression.h
M src/iasm.c
M src/init.c
M src/interpret.c
M src/mtype.c
M src/statement.c
M src/staticassert.c
M src/struct.c
M src/template.c
M src/traits.c
Log Message:
-----------
Refactor optimize(WANTinterpret) -> ctfeInterpret()
This creates a single entry point to CTFE. Separating "const-folding that may
result in CTFE" from a "call to CTFE" causes a lot of unnecessary complexity
and code duplication, and causes bugs like 7640.
Commit: 6a0b71ba23877abb2410abf4dac4f0bd01c84db5
https://github.com/D-Programming-Language/dmd/commit/6a0b71ba23877abb2410abf4dac4f0bd01c84db5
Author: Don Clugston <don.clugston at sociomantic.com>
Date: 2012-05-13 (Sun, 13 May 2012)
Changed paths:
M src/interpret.c
Log Message:
-----------
CTFE: Fix segfault with x ~ error
Commit: aa7939aefcf61d6a44f2d4df15157427f7725fc0
https://github.com/D-Programming-Language/dmd/commit/aa7939aefcf61d6a44f2d4df15157427f7725fc0
Author: Walter Bright <walter at walterbright.com>
Date: 2012-06-13 (Wed, 13 Jun 2012)
Changed paths:
M src/attrib.c
M src/cond.c
M src/declaration.c
M src/enum.c
M src/expression.c
M src/expression.h
M src/iasm.c
M src/init.c
M src/init.h
M src/interpret.c
M src/mtype.c
M src/statement.c
M src/staticassert.c
M src/struct.c
M src/template.c
M src/traits.c
Log Message:
-----------
Merge pull request #969 from donc/WANTinterpret7988
Refactor: create a single entry point for CTFE interpreting
Compare: https://github.com/D-Programming-Language/dmd/compare/687044996a06...aa7939aefcf6
More information about the dmd-internals
mailing list