[phobos] Proposal of StopWatch module
Jonathan M Davis
jmdavisprog at gmail.com
Tue Aug 17 10:51:44 PDT 2010
On Tuesday, August 17, 2010 07:19:32 SHOO wrote:
> (2010/08/17 20:33), Lars Tandle Kyllingstad wrote:
> > Looks good!
> >
> > I just have a few small suggestions:
> >
> >
> > 1. I'd replace fromMseconds and fromUseconds with fromMilliseconds and
> > fromMicroseconds. (Mseconds is, strictly speaking, megaseconds...) And
> > mseconds->milliseconds, useconds->microseconds, etc.
I probably would have just done fromMS() and fromUS() personally. In all the
code that I've generally seen, ms is milliseconds, us is microseconds, and ns is
nanoseconds. I've never even heard of a megasecond (though I can easily believe
that such exists since mega is often used as a unit). But if we're looking for
something with clearer names, then I'd argue for fromMilliSec() and from
fromMicroSec(). Long function names aren't necessarily a big deal IMHO, but if
we can reasonably make them shorter, then we generally should.
- Jonathan M Davis
More information about the phobos
mailing list