Visual D wierdness

Prudence via Digitalmars-d-ide digitalmars-d-ide at
Sun Sep 6 10:47:19 PDT 2015

On Sunday, 6 September 2015 at 09:09:05 UTC, Rainer Schuetze 
> On 03.09.2015 03:57, Prudence wrote:
>> I installed a completely new VS2015 and VD on a new Win10 
>> setup.
>> I compiled a win10 app and it works. I proceeded to add a few 
>> empty D
>> modules.
>> When I add a subfolder then add a d module to it, It first 
>> puts the name
>> ".subfolder.dmodule". (note the . in front)
> I can confirm that there seems something weird. I also got this 
> only after a few attempts.
> Please note that "Add Folder" in the context menu is rather 
> misnamed, it is actually the same functionality as "Add Filter" 
> in C++, i.e. it doesn't create the directory on disk for you. 
> That's done by selecting a package in "New item".
Thanks, I didn't know that. (I ended up creating all the 
directories manually ;/

I have a request related to this though.

When creating a module that is in a folder. VD does not use the 
folder name.

e.g., suppose you have the folder layout X\Y\Z

and add to it a file called q.d. When The file is open one has 
"module q;" instead of "module x.y.z.q;". The latter would be the 
preferred choice I suppose since I'm sure most people keep the 
module names consistent with their location(to avoid all kinds of 
problems). (this generally means if you are working on a large 
project there are many renamings that have to be done)

>> Also, even fixing the project won't compile and returns no 
>> error
>> messages except failed. I've tried to delete the module and 
>> such and got
>> it to compile again. Then tried adding once more and it didn't 
>> work.
>> Trying to remove and close the d module then results in 
>> "insufficient
>> memory to continue execution".
> I cannot reproduce this. Could you provide the output log 
> (*.buildlog.html) in the output folder?
>> When I try to close Visual studio I get "The operation can't be
>> completed. Not enough storage is available to complete this 
>> operation".
>> Using latest of everything.
>> This seemed to only happen when I added a 3rd folder. Must be 
>> a bug in
>> the software around that point.

Not sure. I can't reproduce it so I'm sure it was a glitch/bug 
but probably one of those things. If I run across it again I'll 
try to pay more attention.

More information about the Digitalmars-d-ide mailing list