Dustmite + Visual D

Michelle Long HappyDance321 at gmail.com
Sun Nov 4 21:11:27 UTC 2018

On Sunday, 4 November 2018 at 17:20:41 UTC, Vladimir Panteleev 
> On Sunday, 4 November 2018 at 17:16:55 UTC, Michelle Long wrote:
>> C:\a\b\b\b.dustmite\..\..\..\..\x\y\pegged\dynamic\grammar.d: 
>> The process cannot access the file because it is being used by 
>> another process
>> When I run dustmite on a project.
> As the error message says, the problem occurs because another 
> file is accessing it.

No, have you not learned in your life time that just because 
something or someeone says something doesn't make it true?

> Some common culprits are:
> - Anti-virus / security software, such as Windows Defender. 
> Adding the directory containing the D code being reduced as an 
> exception usually helps.
> - File synchronization software, such as OneDrive / SyncThing.
> - Editors/IDEs. Make sure the directory being reduced is not 
> part of any project/solution open in Visual Studio etc.

Nope, none of this because I run none. Please trust people a bit 
more when they say what they say. Not everyone is an imbecile.

> I think I made Dustmite retry after a second when it gets that 
> error. Is that not the case? Post the full output, if so.

This has nothing to do with dustmite as far as I know. That is 
the full output.

Visual D creates a temp project and when it tries to copy the 
files this error occurs. It is almost surely due to a junction 
issue as I mentioned. (believe me when I tell you I'm not a moron 
so when I say something it generally has some truth in it)

If this is dustmite and not visual D then it most likely is due 
to the junction.

I have used dustmite before and it has worked in visual D, but 
either a regression occurred or it is due to using the 
junction(which is the first project I have created that uses a 
junction and dustmited).

Let me enlighten you a little: The reason why this is most likely 
a junction is:

1. There is little else it could be except visual studio itself 
locking the file, which it doesn't seem to be and has worked 

2. Junctions are known to cause problems with some copy routines 
because one can't simply copy a junction as normal. The reason 
being is the junction suppose to be duplicated or all the data?

e.g., this happens to others:


More information about the Digitalmars-d-ide mailing list