Survey: Can we drop support for LLVM versions prior to 3.5?

Johan Engelen via digitalmars-d-ldc digitalmars-d-ldc at
Fri Apr 10 05:00:23 PDT 2015

I am using LLVM 3.6 and trunk (I build LLVM myself).
The only reason I have builds for 3.4 and 3.5 is to fix backwards 
compatibility issues...

On Friday, 10 April 2015 at 05:56:36 UTC, Kai Nacke wrote:
> Because the LLVM API is not stable this broad support becomes 
> more and more a burden. It is also likely that this set of LLVM 
> libraries will not be supported by the new Travis container 
> (which I like to use because of more RAM and CPU cores).

Is anyone actively working on having green Travis build for LLVM 
3.6+ ?

More information about the digitalmars-d-ldc mailing list