local variable naming convention

bearophile bearophileHUGS at lycos.com
Fri Dec 20 01:30:06 PST 2013


kdmult:

> this(int x, int y)
> {
>    this.x = x;
>    this.y = y;
> }

In D I prefer:

this(int x_, int y_) {
     this.x = x_;
     this.y = y_;
}

Bye,
bearophile


More information about the Digitalmars-d-learn mailing list