local variable naming convention

Boyd gaboonviper at gmx.net
Fri Dec 20 01:49:59 PST 2013


On Friday, 20 December 2013 at 09:30:08 UTC, bearophile wrote:
> kdmult:
>
>> this(int x, int y)
>> {
>>   this.x = x;
>>   this.y = y;
>> }
>
> In D I prefer:
>
> this(int x_, int y_) {
>     this.x = x_;
>     this.y = y_;
> }
>
> Bye,
> bearophile

I concur. And I should probably get used to using 'this' a lot as 
well.

Maybe it would be a good idea to add this kind of information to 
the official coding style guide.


More information about the Digitalmars-d-learn mailing list