Uploading coverage to Codecov doesn't work

Mitacha mateusz.mitaszka at gmail.com
Wed Jul 8 15:55:58 UTC 2020

Hello there,

I've been trying to setup bitbucket pipelines to submit coverage 
to codecov, but with no luck.
I use `dub run -b unittest-cov` and it generates .lst files 
correctly, then `bash <(curl -s https://codecov.io/bash) -t 
$CODECOV_TOKEN` is called, but all I get is:

==> Bitbucket detected.
     project root: .
     Yaml not found, that's ok! Learn more at 
==> Running gcov in . (disable via -X gcov)
==> Python coveragepy not found
==> Searching for coverage reports in:
     + .
--> No coverage report found.
     Please visit http://docs.codecov.io/docs/supported-languages
No reports were uploaded.

The thing I'm concerned about is "--> No coverage report found.". 
I checked and token is supplied. I ran same commands locally and 
get same result.

Is there some magic configuration in yaml file necessary, to make 
that work?

More information about the Digitalmars-d-learn mailing list