doob at me.com
Thu Nov 10 05:43:12 PST 2011
On 2011-11-10 11:21, Jonathan M Davis wrote:
> Well, for better or worse, we don't have an official policy on it. In general, I
> think that the tact is to try and rename the item so that it doesn't pose a
> problem, but that's not always possible (hence FunctionAttribute.pure_). In
> this case, since it comes from something else, it looks like it really should
> be some version of delete. However, whereas FunctionAttribute pretty much
> _had_ to be as close to the keyword as possible since it represented the
> keyword, that's not the case here, and given how ugly it is to tack the _ on,
> del seems like a reasonable solution.
> In any case, if we want something official, we'd have to discuss it, and we
> generally have a hard time coming to any kind of consensus on stuff like that.
> So, I don't generally try unless it seems particularly important.
> - Jonathan M Davis
I think we should write down, somewhere, what we have, what we have
agreed on unofficially. It may not be complete and not contain details
for everything but it would at least be something. Instead of having to
explain this every time we get a new contributor to Phobos or one has to
try to find this information in the newsgroup.
More information about the Digitalmars-d