D dropped in favour of C# for PSP emulator

Mehrdad wfunction at hotmail.com
Fri May 11 12:15:53 PDT 2012


On Friday, 11 May 2012 at 19:03:56 UTC, Chris Cain wrote:
> On Friday, 11 May 2012 at 18:33:06 UTC, Mehrdad wrote:
>> But just because the *reasons* are correct that doesn't mean 
>> it's more intuitive.
>>
>> ("Intuitive", by definition, means that you have a good chance 
>> of getting it right without needing to look it up. Binary 
>> searching in D failed this miserably for me.)
>
> You want a language that you can program in without ever 
> looking at docs? How exactly would that work? o_O

lol I think you're exaggerating my point. :P

I said a "reasonable chance".

For example, in std.algorithm, "joiner" is NOT what I expected
the method to be called -- I expected "join". (Again, I *do*
understand why it's called that.)

Or in std.range, no one in a million years expects to see a
method called "moveFront()". You're not "moving" a range...
What we call "moveFront()" should, IMO, have been called
"popFront()". Or maybe just "next()". But of course that was
taken, so there wasn't a choice. Still, not intuitive.

Heck, even C# has a more intuitive name for setDifference():
it's called "Except".
(Like, items.except(otherItems).)

Or e.g. C#'s "Any()" method tells you whether the collection is 
empty, whereas D's "any()" method takes in a predicate. I find 
C#'s *slightly* more intuitive.

D's std.algorithm.completeSort() definitely does NOT have an 
intuitive name.


etc.


(But, actually, what you said WOULD work if you had a good enough
IDE, like Visual Studio, that gave you the descriptions right
there, instantly. That wasn't my point though.)


More information about the Digitalmars-d mailing list