s/type tuple/template pack/g please

Tommi tommitissari at hotmail.com
Thu Aug 22 04:37:51 PDT 2013


On Wednesday, 21 August 2013 at 17:53:21 UTC, Andrei Alexandrescu 
wrote:
> So: shall we use "template pack" going forward exclusively 
> whenever we refer to that stuff?

I think it should be called either a "compile-time list" or a 
"static list", because it's a list of things which can be 
referred to at compile-time.

import std.typetuple;

void main()
{
     int n;
     alias T = TypeTuple!(int, 4, n);

     static assert(T[1] == 4);
     T[2]++;
     assert(n == 1);
}


More information about the Digitalmars-d mailing list