Parallel execution of unittests

Dicebot via Digitalmars-d digitalmars-d at puremagic.com
Thu May 8 05:56:18 PDT 2014


On Wednesday, 7 May 2014 at 16:09:28 UTC, Atila Neves wrote:
> They can. But those descriptions are not included in failing 
> test output. What I think Jacob might be getting to as well is 
> that assertEquals or the more RSpec-like "foo.should equal 3" 
> is more readable than the raw asserts.
>
> The context matters. In some frameworks that means using test 
> names like testThatWhenIDoThisThenTheOtherThingActuallyHappens 
> (which we'd get if we can have named unit tests), RSpec tries 
> to be more readable but in the end it's all about:
>
> 1) Documenting what the code is supposed to do
> 2) Knowing what test failed and what it was testing

You don't need artificial pseudo syntax for that.
assert!("==") + named tests is good enough to get the context and 
for detailed investigation you need file and line number anyway. 
Stuff like RSpec is extreme opposite of KISS.


More information about the Digitalmars-d mailing list