Named unittests

Jonathan M Davis via Digitalmars-d digitalmars-d at
Tue Mar 31 22:11:01 PDT 2015

On Tuesday, March 31, 2015 14:45:49 Idan Arye via Digitalmars-d wrote:
> But unittests already have
> names(, so the only required
> change is to allow the user to specify that name. This should be
> much simpler than adding entirely new fields.

Exactly what I was thinking. If we just made

unittest myTest



legal, then the unit test function would then be named myTest instead of
whatever it's already named right now. It's a lot less ugly than using
attirbutes, and it fits really well into what we already have. Certainly,
it seems like a very straightforward and simple solution to the problem.

- Jonathan M Davis

More information about the Digitalmars-d mailing list