[OT] Swift removing minor features to piss me off

H. S. Teoh via Digitalmars-d digitalmars-d at puremagic.com
Thu Apr 28 20:11:31 PDT 2016


On Thu, Apr 28, 2016 at 10:49:19PM +0000, Adam D. Ruppe via Digitalmars-d wrote:
> On Thursday, 28 April 2016 at 22:37:41 UTC, H. S. Teoh wrote:
> >Of course, in an ideal world you'd have a "forever" keyword instead,
> >but using up an entire keyword just for this one specific kind of
> >loop seems a little excessive.
> 
> forever: {
>   // stuff
>   goto hell; // who needs break?????
>   // more stuff
> } goto forever;
> hell:
>  {}

Armed with goto, we can completely dispense with complicated,
hard-to-maintain, and trick-to-use superfluous language constructs like
for, if, while, switch, and so on. Who needs if/else and that convoluted
issue of dangling else's, when you could just write goto and be
absolutely clear what exactly is to happen to control flow? And we can
finally jettison throw, thereby eliminating the need for those
cumbersome nothrow annotations and @nogc issues with creating new
Exception objects.  This will reduce the size of the language, make the
compiler easier to maintain, make external parsers easier to write,
etc.. Sounds like win-win to me.  Who's up for drafting up the DIP? :-P


T

-- 
Only boring people get bored. -- JM


More information about the Digitalmars-d mailing list