Should we add `a * b` for vectors?
ilyayaroshenko at gmail.com
Wed Sep 27 07:41:23 UTC 2017
On Wednesday, 27 September 2017 at 04:59:10 UTC, Manu wrote:
> On 26 September 2017 at 21:41, Atila Neves via Digitalmars-d <
> digitalmars-d at puremagic.com> wrote:
>> On Friday, 22 September 2017 at 17:11:56 UTC, Ilya Yaroshenko
>>> Should we add `a * b` to ndslice for 1d vectors?
>>> Discussion at
>> I'd say yes.
> Just remember, it's okay to vote no! Even if it makes you a
> bigoted dick ;)
> In this case, I think 'no' is the only reasonable choice.
> If this is going to seriously be considered, then ndslice
> should definitely
> be renamed to 'matrix'.
> An alternative solution might be to introduce a wrapper of
> ndslice called 'matrix' that supports matrix mul...?
I would prefer outer operator overloading be added to D instead
of type wrappers. So a user can import a library for operations,
rather then library of wrappers. --Ilya
More information about the Digitalmars-d