Should we add `a * b` for vectors?

Manu turkeyman at
Wed Sep 27 04:59:10 UTC 2017

On 26 September 2017 at 21:41, Atila Neves via Digitalmars-d <
digitalmars-d at> wrote:

> On Friday, 22 September 2017 at 17:11:56 UTC, Ilya Yaroshenko wrote:
>> Should we add `a * b` to ndslice for 1d vectors?
>> Discussion at
> I'd say yes.
> Atila

Just remember, it's okay to vote no! Even if it makes you a bigoted dick ;)
In this case, I think 'no' is the only reasonable choice.
If this is going to seriously be considered, then ndslice should definitely
be renamed to 'matrix'.

An alternative solution might be to introduce a wrapper of ndslice called
'matrix' that supports matrix mul...?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Digitalmars-d mailing list