GC buggy in windows?

rikki cattermole rikki at cattermole.co.nz
Fri Nov 8 16:06:50 UTC 2019

On 09/11/2019 4:54 AM, tchaloupka wrote:
> On Friday, 8 November 2019 at 15:30:18 UTC, rikki cattermole wrote:
>> On 09/11/2019 4:21 AM, Dennis wrote:
>>> On Friday, 8 November 2019 at 15:01:26 UTC, tchaloupka wrote:
>>>> All ended up same within a few secs.
>>> I tried it a few times on my Windows 10 laptop with dmd 2.088, it 
>>> just sat there for minutes using ~14% CPU (note: I have 8 logical 
>>> processors) taking 10 Mb, and nothing appeared in the console. So 
>>> unfortunately I couldn't reproduce it either.
>> Yes.
>> This is looking more and more like an environment issue, not a bug on 
>> druntime's end.
>> Potentially AV related (I use Avast) and I'm on Windows 10 Home 64bit.
> Thanks for feedback, I've tried it on more servers where it actually 
> worked as you both described.
> At the end the difference was Eset antivirus installed.
> I had it whole disabled to eliminate exactly this but only after it's 
> uninstall it started to work.. So some crap was still active in it.
> Well still it's pretty unfortunate if some 3rd side app can brick the GC 
> runtime. We can't just say to customers "You've got Eset installed? 
> Screw you it won't work together."
> So bug or not a bug?

Bug on Eset's side.

They are misbehaving in some way.

You can confirm that this is the case by installing an AV like Avast 
with full firewall capability turned on (may need to pay, but worth 
while to confirm).

The reason I am confident that it is a bug on the AV side and not D's is 
because I don't remember hearing about this happening before.

It may be possible to add a workaround on our end, but we'll need Eset 
on our side for that I think.

Based upon a quick search on Google, its looking like Eset consider this 
a feature not a bug. 

More information about the Digitalmars-d mailing list